Audible pop: C22

pyonc

Well-Known Member
Apr 23, 2016
8
0
81
I hear a brief audible pop through speakers (something like sharp electrical squeaking) when I turn off the McIntosh MC 240 power amp hooked with McIntosh C22 tube preamp.
All the functions of C22 are okay, with no hum or noise when turned on, producing great sound.
MC 240 also in great condition.
Now, when I turn off the system, MC240 off first, and then C22 off in that order as supposed.
However, with the match of C22 with MC240, I hear this "pop" when I turn off the MC240.
I tried C24 solid state with MC240, and no popping sound at all.
Any idea or solution? Thanks.
 
Last edited:

About us

  • What’s Best Forum is THE forum for high end audio, product reviews, advice and sharing experiences on the best of everything else. This is THE place where audiophiles and audio companies discuss vintage, contemporary and new audio products, music servers, music streamers, computer audio, digital-to-analog converters, turntables, phono stages, cartridges, reel-to-reel tape machines, speakers, headphones and tube and solid-state amplification. Founded in 2010 What’s Best Forum invites intelligent and courteous people of all interests and backgrounds to describe and discuss the best of everything. From beginners to life-long hobbyists to industry professionals, we enjoy learning about new things and meeting new people, and participating in spirited debates.

Quick Navigation

User Menu

Steve Williams
Site Founder | Site Owner | Administrator
Ron Resnick
Site Co-Owner | Administrator
Julian (The Fixer)
Website Build | Marketing Managersing