Page 3 of 3 FirstFirst 123
Results 21 to 21 of 21

Thread: Supporting "Genesis" Loudspeakers

  1. #21
    Junior Member
    Join Date
    Dec 2014
    Location
    Budapest, Hungary
    Posts
    2

    Thumbs up

    Thanks for your quick reply, Gary! The information certainly helped me understanding the circuit better. In the meantime, I continued drawing the circuit based on the PCB onto a paper. Now I have the last couple of stages (out of the 12!) completed and I finally start to see what's happening here, including the feedback logic and the two trimpots. The term "compression" you used was new to me. I'm not sure if this is the same old Genesis design we can see here but if I understand this correctly the P4 trimpot adjusts the amount of feedback signal derived from the original signal, before entering into the last stage. Before the last stage U1(3), no compression is happening but by looking at the last stage those diodes there do concern me in the feedback loop. It's not clear to me if they act as a log amp and if they do any expansion/compression on the signal at this point but I'd be more happier with a proper linear output without any (logarithimic) compression if that's possible.
    By listening to the sub and adjusting the P4 while playing sound I could certainly tell the difference and luckily this confirms that the accelerometer works as expected. The adjusment in sound as I can hear is an SPL vs. Linearity/Distortion adjustment. I don't have an SPL meter, so for now, I only adjusted this based on some listening tests to find a good middle-road here and I'm happy with the results. I'll probably fine tune this once again if I get the chance. I haven't touched P5 since I don't have any information what is the target voltage at R2 with a reference signal. If by any chance this circuit familiar to you and looks similar to another Genesis mode, please let me know. I'm also interested to take a look at the circuit of the later Genesis 900 sub model if you have it somewhere.

    Schematic of the final stages:
    http://www.digikey.com/schemeit/embed/#18xl

    Also attached as PDF.

    Lastly, going back to my original issue with the sub, the JFETs responsible for muting were causing the problem (no sound). The implementation of mute is very simple; the negative mute voltage is always present when the power supply is ON but for some reason the JFET channels have never got switched off, causing mute to be always active (signal shortened to ground).
    Attached Images Attached Images

Page 3 of 3 FirstFirst 123

Similar Threads

  1. Replies: 162
    Last Post: 04-06-2018, 03:09 PM
  2. "Fast" and "slow" subwoofers: can we put them to bed?
    By twelti in forum Todd Welti Discusses Subwoofers In Rooms
    Replies: 50
    Last Post: 08-16-2015, 12:34 AM
  3. Replies: 54
    Last Post: 01-12-2013, 03:02 PM
  4. Genesis G1 "Dragon" Launch Party - May 4th, 2012
    By carolkoh in forum Genesis Advanced Technologies Forum
    Replies: 67
    Last Post: 08-14-2012, 04:16 PM
  5. Replies: 29
    Last Post: 01-04-2011, 04:56 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •